반응형

전체 글 44

Docker로 LDAP 구축하기

1. Docker 컨테이너 기동(1) 데이터 볼륨 생성docker pull osixia/openldap:latest (2) 데이터 볼륨 생성docker volume create ldap_data docker volume create ldap_config (3) LDAP 서버 도커 컨테이너 실행docker run --name ldap-server \ -p 389:389 -p 636:636 \ -v ldap_data:/var/lib/ldap \ -v ldap_config:/etc/ldap/slapd.d \ -e LDAP_ORGANISATION="Test" \ -e LDAP_DOMAIN="test.com" \ -e LDAP_ADMIN_PASSWORD="admin" \ -e LDAP_TLS=fals..

도커(Docker) 2025.12.17

NFS와 로컬 스토리지의 디스크 작업 성능 비교 : AI 기반 성능 패턴 분석

개요본 보고서는 쿠버네티스 환경에서 NFS와 로컬 스토리지의 디스크 작업 성능을 비교한 테스트 결과를 분석하고, 특히 OpenSearch 사용 관점에서 이러한 성능 차이가 미치는 영향을 평가한다. 다양한 I/O 패턴에 대한 성능 테스트를 통해 OpenSearch 워크로드에 최적화된 스토리지 솔루션 선택을 위한 가이드라인을 제시한다.테스트 환경테스트 노드: worker-10 (동일 노드에서 로컬 및 NFS 테스트 수행)테스트 도구: FIO (Flexible I/O Tester)측정 항목: 읽기/쓰기 대역폭, IOPS, 지연 시간테스트 패턴: 랜덤 읽기/쓰기(4K), 순차 읽기/쓰기(1M), 혼합 읽기/쓰기(4K)성능 테스트 결과 요약대역폭 성능 테스트 유형로컬 스토리지NFS비교순차 읽기(1M)210 MiB..

쿠버네티스 환경에서 레거시 프로세스로 인한 리소스 경합 문제 분석

문제 발생 시나리오쿠버네티스 스케줄러는 노드의 가용 리소스를 기반으로 파드를 배치함.사용자가 특정 노드에서 레거시 프로세스(쿠버네티스 외부)를 실행하면, 이 프로세스는 노드의 리소스를 소비하게 됨.이로 인해 노드의 가용 리소스가, 쿠버네티스 스케줄러가 계산한 것보다 실제로는 더 적어질 수 있음.결과적으로 노드에서 리소스 경합이 발생하여 파드의 성능 저하나 OOM(Out of Memory) 문제 발생. 실제 문제 발생 사례발생 내용 및 시기오픈서치 테스트 중 리소스 부족으로 인한 성능 저하 문제 발생 (2025년 5월 14일 경)오픈서치 접근 시 타임아웃 발생 2025년 5월 19일 조사 결과:특정 노드의 메모리 사용량이 비정상적으로 높은 것을 발견해당 노드에 배포된 리소스 정리 후에도 메모리 사용량이..

마스터 노드 인증서를 사용하여 metrics-server 설치하기

클러스터 환경의 노드와 파드의 리소스 사용량을 모니터링 하기 위해서는 metrics-server 라는 리소스가 필요하다.언제부터인지 kubectl top pod나 kubectl top node 같은 명령어 사용이 불가해졌다.이로 인해 리소스 사용량 추적이 어려워졌다. 이전에 클러스터 환경이 재시작 되면서 인증서 관련 에러가 발생했는데, 누군가 해당 이벤트를 확인하고 deployment를 아예 제거한 것 같다.아래는 인증서 관련 문제를 해결하면서 metrics-server를 설치하는 내용이다.1. 매트릭 서버 설치 여부 확인[user@worker-18 .kube]$ kubectl get deployment -n kube-system | grep metrics-server메트릭 서버가 설치 되었는지 확인하기..

Opensearch 클러스터구성에서 POD(NODE)간 통신 되지 않는 문제

문제 상황클러스터 환경으로 OpenSearch를 구축했을 때 특정 노드가 클러스터에 제대로 조인하지 못하고, 추가되었다가 제거되는 과정이 반복적으로 발생했다.Pod나 다른 리소스를 삭제 후 다시 배포해도 특정 노드에서만 지속적으로 문제가 발생하는 듯 했다.원인 분석주요 원인워커노드 환경 차이: Pod가 서로 다른 워커노드에 배포되어 IP 대역이 다름.opensearch-0: 172.30.14.xxx (worker-1, CentOS Linux 7)opensearch-1: 172.30.19.xxx (worker-2)opensearch-2: 172.30.5.xxx (worker-3, Ubuntu 24.04.2 LTS)세부 원인TLS 인증서 검증 문제:인증서에 IP 주소가 포함되지 않았음호스트네임 검증 시 IP..

쿠버네티스 인증서 관리 - 인증 오류 해결

발생한 오류쿠버네티스 클러스터에서 갑자기 인증 관련 오류가 발생함. "Unhandled Error" err="couldn't get current server API group list: the server has asked for the client to provide credentials""error: You must be logged in to the server (the server has asked for the client to provide credentials)" kubectl이 클러스터에 인증할 수 없었다는 오류 내용. 영향 범위마스터 노드와 워커 노드에서 모두 동일한 인증 오류가 발생함.사용자는 kubectl 명령어(k get pod, k get ingress 등)를 실행할 수 없음. ..

kubectl 명령어 간략 설명

1. 네임스페이스 목록 확인:kubectl get namespaces현재 클러스터에 존재하는 모든 네임스페이스 목록을 표시한다.2. Pod 정보 확인:kubectl get pod -n ${NAMESPACE}지정된 네임스페이스(${NAMESPACE}) 내 모든 Pod 목록과 상태를 표시한다.3. 모든 리소스 목록 확인:kubectl get all -A모든 네임스페이스에서 모든 리소스(Pod, Deployment, Service 등) 목록을 표시한다.kubectl get all -n ${NAMESPACE}지정된 네임스페이스(${NAMESPACE}) 내 모든 리소스 목록을 표시한다.4. Pod 내 컨테이너 실행:kubectl exec -it ${POD_NAME} -n ${NAMESPACE}지정된 네임스페이스(..

[ITExam-CKA] 4. Kubernetes ETCD - etcd 백업 실습

https://www.itexams.com/exam/CKA CKA Exam - Free Questions and Answers - ITExams.com www.itexams.comITExams에서 CKA 자격증 취득을 위한 무료 문제를 제공한다. 오늘은 4번 문항 etcd 백업 문제에 대한 풀이 방법을 공유하고자 한다.  가장 먼저 아래처럼 exit 하라는 내용을 볼 수 있다. SIMULATION -No configuration context change required for this task. Ensure, however, that you have returned to the base node before starting to work on this task:[student@mk8s-master-0]..

카테고리 없음 2025.02.17

[ITExam-CKA] 3. Kubernetes Upgrade - 클러스터 버전 업그레이드 실습

https://www.itexams.com/exam/CKA CKA Exam - Free Questions and Answers - ITExams.com www.itexams.comITExams에서 CKA 자격증 취득을 위한 무료 문제를 제공한다. 3번 문항 클러스터 버전 업그레이드 문제에 대한 풀이 방법을 공유하고자 한다.  가장 먼저 아래처럼 context를 설정하라는 내용을 볼 수 있다.SIMULATION -Set configuration context: kubectl config use-context mk8s 쿠버네티스에서 클러스터를 관리할 때, 사용할 환경을 설정하는 것이다. 위의 내용은 'mk8s라는 이름의 context를 사용하겠다'는 의미이다. 아래부터는 문제 내용이다.[문제]Task -Gi..

[ITExam-CKA] 2. Kubernetes Cluster Management - Cordon과 Drain 실습

https://www.itexams.com/exam/CKA CKA Exam - Free Questions and Answers - ITExams.com www.itexams.comITExams에서 CKA 자격증 취득을 위한 무료 문제를 제공하는데, CKA 2번 문항에 대한 풀이 방법을 공유하고자 한다. 1번 문항과 마찬가지로 가장 먼저 아래처럼 context를 설정하라는 내용을 볼 수 있는데,SIMULATION -Set configuration context: $ | kubectl config use-context ek8s  쿠버네티스에서 클러스터를 관리할 때, 하나의 kubeconfig 파일에서 여러 개의 클러스터, 사용자, 네임스페이스를 설정할 수 있는데, 이러한 클러스터와 사용자 조합을 컨텍스트(C..

반응형